Invalid Path

Jul 7, 2009 at 10:43 PM

Hello,

I have installed the add-in, as well as the required VSE 3.0 included with it.  I've also got .net 3.5, and Office 2007 is fully updated (per Microsoft Update).

The add-in has had problems on two machines in the office.  It does not seem to make any local backups; using the global setting is a little better.  It will sometimes, but not always, create a file in the global backup folder.  These older versions are NOT listed in the versions pane - the pane remains blank.  The files have long, numbered suffixes, but are openable in Word.

I uninstalled, and then installed the PIA version, rebooted the machine.  The first time I loaded it, it gave a red "invalid path" message at the bottom of the version pane.  I saved several changes, and they were shown in the pane.  I closed the document and tried another document, but it stopped working.  It is now behaving just as I described in the first paragraph. 

Can you offer any insight into why this may be happening?  I will gladly answer questions, as we very much wish to use this Add-in.

-Justin

Coordinator
Jul 8, 2009 at 7:21 AM

Hi Justin,

I will take a look at your problem today in the evening.

But here are some steps to let me better reproduce the issue. Please tell me, in which step it behaves not like expected.

Start Word, then do not open a document and go to the settings dialog. Change to "global" and select a path. Make sure it exits and is readable/writable for the current user. Then save and close word. Make sure, the winword.exe is not running anymore. Restart Word, write something in the new document, save, make some changes and save again. Now there should be a new file in the history location and the pane should show one entry. If this is working -> cool. ;-)
If you then start word again, open the previously saved file, it also should show one entry in the history pane.

If everything is fine until this step, then make sure the problem is not document related (maybe a document with macros, etc and you didn't click the "enable" button in the yellow bar at the top)

Jul 8, 2009 at 3:45 PM
Hi Marcow,

Thank you for your quick response.  I rebooted my machine, and did just as you said.  I changed to global, and created a new folder "test backup" within "My Documents", and verified that it exists.  I *believe* it is readable/writable.  I am using an administrator account on xp sp3.  I can freely move files into and out of the folder, and save changes to documents within the folder.  I closed Word 2007, and verified that winword.exe was not listed under processes in the task manager. 

When I opened Word, I selected the "show/hide history" checkbox in the ribbon.  I typed and saved it to the desktop - the words "The path is not of a legal form." appeared within the sidepane, in red letters.  I typed changes, and saved again.  A previous version appeared in the history sidepane, and a folder containing the previous version was created.

So far, so good.  It updated nicely with each save - so cool!

Then, I closed the window.  I re-opened from the file, but the history sidepane was no longer visible, and the checkbox in the ribbon was empty.  I checked the box, and the pane was visible, but empty.  I made changes and saved, but no versions were in the pane.  Files were created, just not listed in the pane. 

I closed it and re-opened it, and tried again.  This time it worked. 
I opened another document - it did not work.
I tried the original document again, and it did not work.

Sometimes, after a restart, it works perfectly.  I can compare versions and everything (which is really amazing, and well done.)
It never retains the checkbox to make the history visible.
I do not think it has ever retained a list of the files created in an earlier session. 
It does seem to create backups in an appropriate directory when you save, most of the time.
The "illegal path" message only shows up after the first save, and only when it is working.  There is no error when things go wrong.
When it is not working, even several changes and saves in a row will generate only one file.

I hope that some of this information helps.  I am very pleased by what you have built, and hope that you have some ideas on how to get things going.  Has anyone else had similar issues?

-Justin



marcow wrote:

From: marcow

Hi Justin,

I will take a look at your problem today in the evening.

But here are some steps to let me better reproduce the issue. Please tell me, in which step it behaves not like expected.

Start Word, then do not open a document and go to the settings dialog. Change to "global" and select a path. Make sure it exits and is readable/writable for the current user. Then save and close word. Make sure, the winword.exe is not running anymore. Restart Word, write something in the new document, save, make some changes and save again. Now there should be a new file in the history location and the pane should show one entry. If this is working -> cool. ;-)
If you then start word again, open the previously saved file, it also should show one entry in the history pane.

If everything is fine until this step, then make sure the problem is not document related (maybe a document with macros, etc and you didn't click the "enable" button in the yellow bar at the top)


Coordinator
Jul 8, 2009 at 6:51 PM

Hi,

The "illegal path" error message should be no problem. It is only the first time visible when the document is new and not saved.

I changed some things and uploaded a new version (1.0.7). In this version (http://autohistory.codeplex.com/Release/ProjectReleases.aspx?ReleaseId=29930), you should see an error message if the settings cannot be saved! This is, what I think happens on your machine.
Please try it.

I, however, cannot reproduce this behaviour. For me it is working, also with the global setting. Have you tried to use the "local" setting and see if this is working?

Jul 8, 2009 at 7:52 PM
Hey,
I uninstalled 1.06, downloaded and installed 1.07. The settings
for my old save folder were still present in the new install. I changed
it back to local. I made a new file on the desktop, and the versions
were properly showing up in the sidepane. I left the "show history"
box checked, and exited. When I opened the file again, there were two
sidebars! previous versions showed in the sidebar on the far right. I
made more changes and saves, all of which showed up in the far-right
sidebar. I tried unchecking the "show history" box, and the left
(empty) sidebar would show/hide. No new error messages... Also I did
not see any files/folders being created on the desktop. Yet, the old
versions could be opened through the far right sidepane. I can send you
a screenshot if you would like.

When I switched the setting to global, it basically did the same thing.
It works, but displays two sidepanes on the right. The primary
difference, is that when in global mode I can see the files/folders that
are being created.

I have not seen any new error messages per se. Is there any way that a
third-party program or setting within Word could be causing this?

-Justin
Coordinator
Jul 8, 2009 at 8:24 PM

Ok, first of all:
The history folder in "local" mode (which is called ".AutoHistory") is made invisible (hidden attribute). You should see it, if you enable "show system files" in explorer->options->advanced, or so.

The two sidebars can be caused by the fact, that it not uninstalled correctly. Try this: Uninstall auto history completly again. Then open word and go to OfficeButton->WordOptions->AddIns->click GO next to the dropdown box (which should show "com addins"). Then remove the "auto history" entry if there is something left. (maybe you have to open word as administrator under vista to remove the add-in)
Then install 1.0.7 again. Should be only one sidebar now. If not, go again to the com addins and if there are two autohistory entries remove one of them.

Ok, but you say there are no error messages and everything is working fine in local mode, but not in global mode, right!? Then I don't know what can be causing this. Maybe the global path is a UNC path or a network folder? Try to create a new folder in C:\ and use this as the global history location.

Are u using XP or Vista or 7?

Jul 8, 2009 at 9:57 PM
Allright, I uninstalled. Reinstallation works, both in local and global
mode. I still get two panes, though. The checkbox will show/hide only
the left, empty pane. Closing both panes with the "x" will hide the
panes. Re-opening the files brings back both panes - versions are only
showing up in the right hand pane.

I tried installing on a clean machine, fully updated. This machine
would not let me use the global option, giving "error saving settings!
... Object reference not set to an instance of an object at
AutoHistory.SettingsForm.buttonOk_Click(Object sender, EventARS e)"

This machine also displays two panes on the right. coms add-ins shows
only one version.

I am using Windows XP Professional Version 2002 Service Pack 3, .Net 3.5
sp1, and Word 2007 (12.0.6504.5000) SP2 MSO (12.0.6425.1000)
The global folder is on the desktop - nothing strange about the path.

I'm starting to wonder if it isn't some strange interaction with F-Secure...

-Justin
Coordinator
Jul 9, 2009 at 6:38 AM

This is really strange!

I will test it later today on a blank XP VM too. I will get back to you as soon as I know what the problem is...

Jul 14, 2009 at 8:09 PM
Marcow,
I was wondering if you had any ideas, or had made any changes to
1.07. We are primarily going to use AutoHistory as an automatic backup
- I am considering just going ahead with the add-in as is. If you are
still tinkering, though, I plan to wait. Any news? Any way I can help?

-Justin
Coordinator
Jul 17, 2009 at 10:25 AM

Hi,

Sorry, that I'm not here the last days.

I really want to investigate, what the problem could be, but at the moment you should go with this version (if it is working!?)

Maybe I will find some time this weekend...